[kepler-dev] Building kepler & ptII in Eclipse

Dan Higgins higgins at nceas.ucsb.edu
Tue Feb 26 10:05:26 PST 2008

Hi All,
    I made some changes to the ant build file yesterday that may impact 
the Eclipse build. Since I don't use eclipse, someone who does may want 
to check out these changes.

1) I removed these exclude statements from build-ptolemy.xml
<!--          <exclude name="ptolemy/domains/dde/**"/>
          <exclude name="ptolemy/domains/dde/kernel/test/test.tcl/**"/>
          <exclude name="ptolemy/domains/dde/kernel/DEThreadActor.java/**"/>
          <exclude name="ptolemy/domains/de/kernel/DEEDirector.java/**"/>
          <exclude name="ptolemy/domains/de/kernel/DETheadActor.java/**"/>
in order to get the head of Ptolemy CVS to compile (under ant)

2) I also removed the exclude for the python actors

<!--          <exclude name="ptolemy/actor/lib/python/**"/>         -->

Dan Higgins

Matthew Jones wrote:
> Yes, you should be able to build from the HEAD.  Check your .classpath 
> file against the .classpath.default and be sure they match. If not, then 
>   copy .classpath.default onto your .classpath file and refresh, being 
> careful of course to not overwrite your local changes if any.  If you 
> still get compile errors, then we probably need to update 
> .classpath.default -- sometimes changes sneak in that we don't catch in 
> the Eclipse files.  One recent change has been in the IOPort* classes, 
> which were recently moved from Kepler's exp directory back into the 
> Ptolemy tree -- this means that the previous exclusions for these files 
> need to be removed from .classpath.  The updated .classpath.default 
> should reflect this. If you are getting class not found errors for 
> IOPort and related classes, this is probably the problem.
> Matt
> Paul Allen wrote:
>> Quick question: Should I be able to build kepler and ptII from the HEAD 
>> of those CVS repositories at this point in time?
>> I had been using Eclipse for development using a mid-Nov. version of 
>> those sources. Following the instructions in 
>> http://www.kepler-project.org/Wiki.jsp?page=UsingEclipseForKeplerDevelopment 
>> worked like a charm to get things running in Eclipse.
>> Just yesterday I updated both kepler and ptII from the HEAD of both CVS 
>> repositories. The only change I made to what I got from CVS was to replace
>>     <classpathentry kind="lib" 
>> path="lib/jar/opendap/opendap-Not.A.Release.jar"/>
>>     with
>>     <classpathentry kind="lib" path="lib/jar/opendap/opendap-0.0.8.jar"/>
>>     in kepler/.classpath.default
>> Most of the problems seem to be classes that are missing from the ptII 
>> HEAD. Anybody else experiencing this?
>> Thanks,
>> -Paul
>> _______________________________________________
>> Kepler-dev mailing list
>> Kepler-dev at ecoinformatics.org
>> http://mercury.nceas.ucsb.edu/ecoinformatics/mailman/listinfo/kepler-dev

More information about the Kepler-dev mailing list