[kepler-dev] Some quick questions

Matthew Jones jones at nceas.ucsb.edu
Wed Apr 4 08:55:39 PDT 2007

Colin --

To map an icon you need to add it to one of the icon mapping property 
files, either by LSID or classname or both:

These are in configs/ptolemy/configs/kepler

In general you should choose one of the existing icons, which are 
categorized by functional groupings.  The older _iconDescription 
approach from Ptolemy is not used in Kepler.

There is no unified properties file for Kepler, but several others exist 
in that directory that might be of use to you for setting system level 
options -- we've used config.xml for most system level properties.

As far as your startup problem -- I'm not sure, but I suggest you clear 
your karlib by doing an ant full-clean before a full rebuild (including 
ant buildkarlib). Did you add an actor to the mix, and if so, have you 
tried a clean build without it to be sure its not something you added?



Matthew B. Jones
jones at nceas.ucsb.edu                Ph: 541-888-2581 ext. 287
National Center for Ecological Analysis and Synthesis (NCEAS)
UC Santa Barbara

Colin Enticott wrote:
> Hello,
> I have a few (hopefully) quick questions.  I've just started developing in
> Kepler after the recent visit by Ilkay Altintas and have successfully
> created an actor for our project Nimrod using the NimrodJavaAPI interface.
> I was wondering how you set an icon for an actor?  I followed the tutorial
> which suggests setting "_iconDescription", but I didn't have any success.
> Doing a search on the wiki suggests that the icon system is/has changing?
> Is there a convention where to set system level options?  E.g. the
> NimrodJavaAPI needs to know where Nimrod is installed.  Currently, I have
> this information set in the Unix environment.  Ideally, this should be set
> in the "system properties" in the Java environment, but I am not sure where
> this can be set.  Is there a Kepler properties file somewhere?
> And finally, I recently did a cvs update on both Kepler and ptII and now
> when I run kepler for the second time (not the first), I get this error
> (looks like an error loading the cache):
>      [java] Opening user preferences PtolemyPreferences.xml...     [java]
> KAR Library directories: [/remus/cme/kepler/kepler/kar/actors,
> /remus/cme/kepler/kepler/kar/directors]     [java]
> com.microstar.xml.XmlException: name expected (found " ") in [external
> stream] at line 84 and column 11
>      [java]     at ptolemy.moml.MoMLParser.error(MoMLParser.java:1006)
> ...
> Kepler then runs without any components being displayed. (I can make the
> whole error available if this error seems odd).  Any thoughts?
> Thanks,
> Colin
> ---
> Colin Enticott, Research Scientist, Ph: +61 03 9903 2215
> Room H7.26, Level 7, Building H, Monash University Caulfield 3145, Australia
> _______________________________________________
> Kepler-dev mailing list
> Kepler-dev at ecoinformatics.org
> http://mercury.nceas.ucsb.edu/ecoinformatics/mailman/listinfo/kepler-dev

More information about the Kepler-dev mailing list