[kepler-dev] Using SCommand in Kepler

Efrat Frank efrat at sdsc.edu
Wed Mar 2 10:03:05 PST 2005


I just tested the SPut actor both under Windows and Mac and it works fine.
As I mentioned before, it's best to you use the CVS version other than
applying patches to the alpha4 release (or alternatively, you can now use
the alpha5 release).

Using the CVS version, you'd also be able to use the debugger or add
printouts to the code to locate the source of the exception (as I'm working
under Windows OS, I can only test actors under Linux/Mac, but it's harder
for me to detect specific exceptions).


----- Original Message ----- 
From: "Tim Wong" <thwong at gmail.com>
To: <srb-chat at sdsc.edu>; <kepler-dev at ecoinformatics.org>
Sent: Wednesday, March 02, 2005 12:17 AM
Subject: [kepler-dev] Using SCommand in Kepler

> Dear all,
> I tried to excute the following sequence of SRB SCommands in Kepler:
> Sinit --> Sput -vf hello.txt --> Sls --> Sexit
> I tried using the Command line actor in Kepler.  The SCommand shows up
> on the Kepler execution shell; however, the command is actully not
> being executed (my file is not uploaded to the SRB space).  I tried to
> capture the output of each command using display windows; nothing show
> up.
> I tried using the External Execution actor.  The SCommand "Sls" raises
> the exception" Sls returned a non-zero return value of 3..."
> Any idea of how to invoke SCommand in Kepler?
> I did not use the Kepler SRB actors b/c I have a hard time getting
> them to work properly.
> Thank you so much.
> Tim
> _______________________________________________
> kepler-dev mailing list
> kepler-dev at ecoinformatics.org
> http://www.ecoinformatics.org/mailman/listinfo/kepler-dev

More information about the Kepler-dev mailing list