[kepler-dev] Web services and SRW

Matt Jones jones at nceas.ucsb.edu
Wed Aug 24 10:59:37 PDT 2005


Welcome to the project!

I think your issue can be traced to limitations of the Web Services
actor.  Currently, the web services actor only supports a limited subset
of the WSDL specification.  In particular, all of your ports need to be
simple types or arrays of simple types for it to work.  The use of
complex types in port definitions is not currently supported using the
Web Services actor.  This is a known limitation of the web services
actor that several people have worked on but for which we have not found
a suitable solution.  The problem arises in how to marshal and unmarshal
arbitrary XML structures into Ptolemy types without any previous
knowledge of the mapping between the XML Schema and ptolemy types.  Most
web service engines handle this by allowing the user to configure stub
classes to a serializer/deserializer -- but this is cheating in that the
web services actor is supposed to work with only the WSDL as input
information.  So...ideas are welcome, and several people are thinking
about the issue and trying to solve it, but for now we are finding it
somewhat difficult.


PS Some of your bindings and encodings may also introduce problems, but
we'll need to talk to Ilkay about that when she returns from vacation.

Fabio Corubolo wrote:
> Hello all,
> I am new here, I am working on a Kepler actor to access IR systems with
> the SRW SOAP protocol (http://www.loc.gov/z3950/agency/zing/srw/) .
> I have been trying to first use the generic web service actor included
> in Kepler, providing it with the following WSDL:
> http://srw.cheshire3.org/wsdl/spy.wsdl
> Problem is I get a single input port, where I should pass it many
> parameters (including version, query etc.). Particularly, using the
> included Axis libraries, the namespace for the request is not included.
> I tried in different ways, also using the new Axis library (1.2.1), but
> I always end up with a single input port. I understand it depends on the
> structure of the WSDL file, the port seem to be waiting for a complete
> "SearchAndRetreiveRequest" object, but even providing the full XML
> request doesn't solve the problem, since the request gets escaped (&lt
> etc).
> Does anybody has any suggestion or previous experience on this? As I
> said, I am new to Kepler development, so I think there may be some other
> solution.
> Thanks,
> Fabio Corubolo
> ------------------------------------------------------------------------
> _______________________________________________
> Kepler-dev mailing list
> Kepler-dev at ecoinformatics.org
> http://mercury.nceas.ucsb.edu/ecoinformatics/mailman/listinfo/kepler-dev

Matt Jones                                     jones at nceas.ucsb.edu
http://www.nceas.ucsb.edu/    Fax: 425-920-2439    Ph: 907-789-0496
National Center for Ecological Analysis and Synthesis (NCEAS)
University of California Santa Barbara
Interested in ecological informatics? http://www.ecoinformatics.org

More information about the Kepler-dev mailing list