[kepler-dev] EML200DataSource Problems

Chad Berkley berkley at nceas.ucsb.edu
Thu Oct 7 10:57:44 PDT 2004

I just tried this and get the same results...when i drag the bears 
dataset out, it has no ports.  I then move the actor on the canvas and 3 
ports appear.  If I search for datos, find the datos dataset then drag 
it out, it has no ports.  i then move the datos dataset and a bunch of 
ports appear on the actor.  the bear actor, however, does not change 
when i move the datos dataset.  I did not see that the number of ports 
for the bear actor was incorrect, although the first time i tried this, 
kepler completely froze while I was doing the 2nd search.  I couldn't 
repro that though.


Dan Higgins wrote:
> Hi Rod,
>    I was playing around with the Data tab in Kepler and ran into some 
> strange behaviors (bugs?) that you may know how to fix (unless it is 
> just on my machine).
> 1) Open a new Graph Editor. Then click on the 'Data' tab and search for 
> 'bear'. The dataset "Bears are Really big" will appear in the tree. Drag 
> it to the panel on the right. Everything is OK so far. [I see that now 
> no output port no automatically appear and that one has to "Look Inside" 
> to configure a table. I think it might be useful to have a default 
> output of the table as a string (or a parameter to set that)].
> 2) Before you 'Look Inside', just drag the icon around to a new 
> location. Three output ports appear when you finish moving the actor!
> 3) Now do another search (leaving the 'bears' actor in place), say for 
> 'datos' and drag the result to the right. Now move this second actor. I 
> get a bunch of output ports appearing on BOTH the datos and the bear 
> dataset! The number for the 'bears' actor is NOT correct!
> Can you reproduce this?
> Dan

More information about the Kepler-dev mailing list