[kepler-dev] Build Problems

Kenneth Evans evans at aps.anl.gov
Tue Oct 30 09:21:37 PDT 2007


This thread was in "RE: [kepler-users] (no subject)".  Sorry about the (no
subject).  It seems like it should be in kepler-dev, so I'm  making a new
thread.  Sorry about that, too.

Executive summary for the hurried:

1. Started completely over.
2. Still have problems with 1 shutdown.bat.
3. Ant build fails. Output attached.
4. Can get Kepler to launch anyway (after putting quotes around -DKEPLER,
etc. paths)
5. Kepler doesn't work right. Output attached.
6. Vergil works OK.


OK I started over.  Took longer than I remembered, and I was unable to do it
at home.  I thought the shutdown.bat problem was fixed, but there seems to
be one of the two still there.  This causes CVS to stop the checkout.  I got
around that by doing a synchronize, override and update, on individual
folders after what it did mange to complete.  I now only have a discrepancy
for ptII on:


I followed the Eclipse instructions.  I did not change the .classpath and I
did not turn on build automatically.  I just did the Ant build with
full-clean Ptolemy buildkarlib run-dev and KEPLER and PTII defined.  It ran
out of memory.  I then fixed the build to use -Xmx256M.

It then failed.  The output is attached.  I must have done something wrong,
but I don't see it.

I then copied the .classpath.default to .classpath for Kepler, not ptII.  I
still get the 11 errors.

Unlike the others I can't run the launcher after saying OK to proceed with

The first reason was that I needed to put quotes around the definitions of
DKEPLER and DPTII since my projects are in My Documents and the path has
spaces.  (I probably could have set the environment in the launcher instead
of specifying command-line arguments.)  This should probably be added to the

After that it still doesn't run.  The output is attached.  It has problems
with the archives that are probably related to spaces in the filenames.  (I
will say ahead of time that I will be resistant to moving my Eclipse
workspace. ;-)

In ptII I copied .classpath.default to .classpath.  I set up a launcher for
Vergil and it works OK.  It even finds and uses my actors out of my Eclipse
actor project.


-----Original Message-----
From: kepler-users-bounces at ecoinformatics.org
[mailto:kepler-users-bounces at ecoinformatics.org] On Behalf Of Kenneth Evans
Sent: Monday, October 29, 2007 4:25 PM
To: Kepler Mailing List
Subject: [kepler-users] (no subject)


I did a synchronize with the Ptolemy CVS and found no discrepancies.  I did
this on Saturday.  That site is changing, however, and would now show

The second problem (also mentioned in a previous post) is that MacAfee
immediately removes shutdown.bat (2) during CVS updates or checkouts.  This
seems to foul up CVS.  According to our IT department, shutdown.bat could be
changed as follows:

McAfee seems to only detect:
"C:\WINDOWS\system32\shutdown -r -t 0 -f"

and if you change the string slightly:
"C:\WINDOWS\system32\shutdown -r -t 1 -f"

"C:\WINDOWS\system32\shutdown -r -f -t 0"

I cannot prevent the deletion at work, so fixing it so there is no false
positive would be good.

I have already redone the checkouts twice, and it is pretty time consuming.
Perhaps I can do it again at home, where I don't get the MacAfee problem.

Later:  Following Chad's suggestion I did full-clean ptolemy run-dev and got
the same error.  (This is what I did before with the addition of


Kepler-users mailing list
Kepler-users at ecoinformatics.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: kepler.build.output
Type: application/octet-stream
Size: 113050 bytes
Desc: not available
Url : http://mercury.nceas.ucsb.edu/ecoinformatics/pipermail/kepler-dev/attachments/20071030/2d1bb85e/kepler.build-0001.obj
-------------- next part --------------
A non-text attachment was scrubbed...
Name: kepler.run.output
Type: application/octet-stream
Size: 4047 bytes
Desc: not available
Url : http://mercury.nceas.ucsb.edu/ecoinformatics/pipermail/kepler-dev/attachments/20071030/2d1bb85e/kepler.run-0001.obj

More information about the Kepler-dev mailing list