[kepler-dev] RE : RE : [kepler-users] matlab expression problem

Matthew Jones jones at nceas.ucsb.edu
Sat Jan 6 08:21:23 PST 2007

You can recompile if you are using a version checked out from CVS by 
using the provided ant 'run-dev' task.  See the documentation about how 
to build and run Kepler on the wiki (http://kepler-project.org).

If you have located a bug or limitation in the ExecuteCommand actor, 
could you please summarize the changes needed to fix it on windows 2003, 
and if possible post a patch to the kepler-dev list?  Thanks.

Mehmood Yasir wrote:
> thanks :)
> I got the problem, its actually an "if" condition in the code of ExecuteCommand actor, which does'nt cater for the "windows 2003" and my remote server is actually windows 2003.
> Now I have to change the code accordingly, can plzz tell me, how I can recompile the Kepler to update it?
> Best Regards,
> yasir.
> -------- Message d'origine--------
> De: Matthew Jones [mailto:jones at nceas.ucsb.edu]
> Date: sam. 06/01/2007 04:02
> À: Mehmood Yasir
> Objet : Re: RE : [kepler-users] matlab expression problem
> Hi,
> I'm not sure what the differences are there.  Maybe its the JVM, maybe 
> not.  It could also be configuration difference (e.g., PATH environment 
> variable) on the two machines making the executable inaccessible on one 
> machine but not the other.
> Matt
> Mehmood Yasir wrote:
>> Dear Jones,
>> thanks a lot too make my directions right otherwise I would have been lost into buggs :)
>> anyways, one more thing if you can help me and that is 
>> if I try to execute a command on windows (using Kepler) by ExecuteCommand actor on one machine it executes and on other i does'nt , i have diff. versions of JVM on both machines 
>> is it bcoz of that ?
>> or bcoz of, that I am executing the command by Remote Login (mstsc)
>> thanks,
>> yasir.
>> -------- Message d'origine--------
>> De: Matthew Jones [mailto:jones at nceas.ucsb.edu]
>> Date: jeu. 04/01/2007 18:47
>> À: Mehmood Yasir
>> Cc: Kepler-users at ecoinformatics.org
>> Objet : Re: [kepler-users] matlab expression problem
>> I suspect the MatlabExpression actor that you are using is the one 
>> developed at SDSC as part of Kepler, not the JNI version that ships with 
>> Ptolemy.  So I'm not sure Christopher's suggestion will help there.
>> With other similar actors (e.g., RExpression), we've had difficulties 
>> with GUI output and had to include specific support for the graphics 
>> subsystem -- I'm not sure if that kind of support was built into the 
>> Kepler MatlabExpression.  Maybe Ilkay and others at SDSC can provide 
>> more information, and Dan Higgins could provide the information about 
>> how it was done in the RExpression actor.
>> In addition, on the MacOS platform we've seen display problems in R due 
>> to the need for X11 to be installed and having trouble with the display 
>> environment.  Dan Higgins might be able to help with this aspect of 
>> things if indeed that is the problem.
>> Good luck, and we'd love to hear if you find a solution,
>> Matt
>> Christopher Brooks wrote:
>>> Try running the Matlab interface from within Ptolemy by invoking
>>> $PTII/bin/vergil -jni.
>>> You may need to build Ptolemy from sources to get $PTII/bin/vergil -jni
>>> to work. 
>>> The reason is that the Java Native Interface (JNI) is buggy.
>>> "$PTII/bin/vergil -jni" starts up .exe file created from C code
>>> (sources are in $PTII/jni/launcher) which then invokes Java.
>>> This seems to work a little better for JNI code.
>>> I'm not sure how to invoke the launcher from Kepler.
>>> _Christopher
>>> Christopher Brooks (cxh at eecs berkeley edu) University of California
>>> Programmer/Analyst Chess/Ptolemy/Trust        US Mail: 558 Cory Hall #1774
>>> ph: 510.643.9841 fax:510.642.2718	      Berkeley, CA 94720-1774
>>> home: (F-Tu) 707.665.0131 (W-F) 510.655.5480  (office: 400A Cory)
>>> --------
>>>     Hi,
>>>     I am making workflows for my lab in KEPLER. Now I have a task in which I ha
>>>    ve to run a matlab script which actually shows a GUI. I tried with MatlabExp
>>>    ression by
>>>     giving expressions as : path to .m file
>>>     executable path : path to matlab executable
>>>     but each time I run this workflow I got message like "something gone wrong 
>>>    with matlab" etc.
>>>     even I tried very simeple expressions which does'nt create some GUI e.g.  
>>>     answer=ones(4)
>>>     still I used to get the same error
>>>     can someone plzz tell me what I am missing or if you can suggest alternativ
>>>    es it would be gr8 
>>>     Best Regards,
>>>     Yasir.
>>>     _______________________________________________
>>>     Kepler-users mailing list
>>>     Kepler-users at ecoinformatics.org
>>>     http://mercury.nceas.ucsb.edu/ecoinformatics/mailman/listinfo/kepler-users
>>> --------
>>> _______________________________________________
>>> Kepler-users mailing list
>>> Kepler-users at ecoinformatics.org
>>> http://mercury.nceas.ucsb.edu/ecoinformatics/mailman/listinfo/kepler-users

Matthew B. Jones
jones at nceas.ucsb.edu                Ph: 541-888-2581 ext. 287
National Center for Ecological Analysis and Synthesis (NCEAS)
UC Santa Barbara

More information about the Kepler-dev mailing list