[kepler-dev] [Bug 2809] New: - Browser Display actor fails for Mac/Linux

Dan Higgins higgins at nceas.ucsb.edu
Fri Apr 6 09:29:03 PDT 2007

Hi Glen,
    Could you please try a new version of the Kepler nightly zip 
(kepler20070405 or later).

    I traced the problem down to the filename, rather than the Browser 
actor itself. If you look at the ImageDisplay workflow you will see a 
Constant on the left that defines an image file with the expression

The 'property("KEPLER")' part of this expression returns the value of 
the property "KEPLER" which is supposed to be the path to wherever the 
Kepler package is installed. KEPLER is actually an environment variable 
set when Kepler is launched. If you look at the old shell script 
(kepler.sh) for launching kepler, you will see that the java command 
line include "-DKEPLER=./". This set $KEPLER to './' The above 
expression would then evaluate to
".//demos/getting-started/species-distribution.jpg" and the 'double 
slash at the start is an illegal path!. So the older version should work 
if you just enter the actual complete path on your computer to the image 

I revised the kepler.sh shell script to insert the actual path for the 
$KEPLER variable rather than use ./

Hopefully this was the only problem (Incidently, I did not see this 
problem at first because I was using the developer version and ant, 
along with a custom version of the $KEPLER env variable. My setting for 
$KEPLER did not have a '/' at the end of the path and this worked!)

Dan Higgins

Glen Jarvis wrote:
> Dan,
>    Actually, I had not removed $HOME/.kepler. In fact, I had several 
> other nightly build directories that I had thought I had removed, but 
> had missed. I removed all of those directories, including 
> $HOME/.kepler. However, the problem still occurs with the ImageJ actor 
> as well as the "Browser Display" actor.
>    However, after this cleanup, I still see the same problem:
>> glen-jarvis-computer:~/kepler20070404 gjarvis$ ./kepler.sh
>> KAR Library directories: [./kar/actors, ./kar/directors]
>> 528 ms. Memory: 94188K Free: 28515K (30%)
>> Reading from the browser - val = false
>> 2007-04-04 19:24:18.103 java[521] LSOpenFromURLSpec() returned -43 for
>> application (null) path 
>> //Users/gjarvis/kepler20070404/demos/getting-started/
>> demos/getting-started/species-distribution.PNG.
>> 436 ms. Memory: 94188K Free: 22782K (24%)
>> glen-jarvis-computer:~/kepler20070404 gjarvis$
> Is there any other clean-up I should do?
> Warmest Regards,
> Glen Jarvis
> --913-486-8775
> glen at glenjarvis.com
> http://www.glenjarvis.com
> "You must be the change you wish to see in the world." -M. Gandhi
> Glen,
>    Thanks for checking this! I tried it on my Mac and it worked OK 
> (with the CVS head) so I will have to see if I can reproduce your 
> problem. I'll probably have to get back to you.
> Dan

Dan Higgins                                  higgins at nceas.ucsb.edu
http://www.nceas.ucsb.edu/    Ph: 805-893-5127
National Center for Ecological Analysis and Synthesis (NCEAS) Marine Science Building - Room 3405
Santa Barbara, CA 93195

More information about the Kepler-dev mailing list