[kepler-dev] Why I can't work: a plea for stability

Sivagowri Swaminathan sivagowri at hotmail.com
Thu Apr 20 14:27:44 PDT 2006

Hi Chris and everyone involved with the kepler project

I wanted to write this email a bit earlier but was held up due to some 
assignments. I got the kepler code running by blindly following your 
description on the setting up kepler with eclipse page.

I experienced a lot of difficulties in setting up the system, as I was an 
outsider without much knowledge about kepler system. But the problem with 
the documentation is that it works only by linking eclipse directly with 
If I downloaded the files from CVS and tried to set up the kepler project in 
eclipse, it kept complaining about null pointer exceptions, cacheManager was 
trying to insert into a record with 5 colums into a table containing 4 
columns [cachecontentTable]...etc. That table is maintained in a remote 
database and nothing could be done about the error.
so as such I kept flushing the project and refreshing from CVS about 10 
times per day.
Finally it struck me to just blindly connect eclipse to cvs using the 
documentation and let eclipse decide whatever it wants to download.

Miraculously it worked. kepler ran and it happened in a wink of time.
I also completely deleted the .kepler directory in documents and 
settings\user folder.
The documentation should be clear about which folder to linkto the project.
Initially I thought that we need to link the ./kepler/kar directory.
But then it was empty so after much thought I linked to the kepler\kar 

That is currently the documenattion reads:

<_ _ _ "On first execution, the kar archive files will be expanded into a 
hidden directory. On unix this directory is ~/.kepler/kar, and on Windows it 
is c:/Documents and Settings/USER/.kepler/kar. Immediately terminate Kepler.

In Eclipse, open the Package Explorer with Window -> Show View -> Package 
Explorer. Right click on the Kepler project in the Package Explorer and 
select New->Folder. Name the folder "karclasses". Click on the Advanced 
button and check "Link to folder in the file system". Browse to the kar 
directory and click "Finish". _ _ _ >

it should read, ignore/delete the kar directory found in the c:/Documents 
and Settings/USER/.kepler/kar directory and then Browse to the kar directory 
found in the kepler download directory and click "Finish".

The reason for confusion was that the ./kepler contained a cache dir, which 
made me think it conatins functionality relating to the cacheManager.

Then as matt suggested in one of his emails to me, the images were not 
getting loaded. so we need to add the images location in the classpath entry 
in eclipse.

But then finally I managed to get the kepler code running and also created a 
custom actor.

I also have the kepler exe installed and whenever I use kepler.exe in 
between running kepler from the devlopment environment, I noticed the 
database conflicts that christopher mentioned.
Each time i had to delete the ./kepler directory and it works.

Thanx for everyone who helped me in my ordeal.

Mrs. Sivagowri Swaminathan

>From: "Christopher Brooks" <cxh at eecs.berkeley.edu>
>To: kepler-dev at ecoinformatics.org
>Subject: [kepler-dev] Why I can't work: a plea for stability
>Date: Thu, 20 Apr 2006 12:48:31 -0700
>I'm not actually upset or anything, but I thought I'd give
>you an outsider's perspective.
>I'm one of the worst offenders here, since I know I broke the build
>yesterday which my diva related changes.  I had things working
>in one tree, but was not able to test because of a problem in
>my other tree on another machine.
>Basically, I thought on my other tree I had broken something
>and spend several hours tracking down the problem as being that
>some geon actors were removed, but geon.xml was not updated.
>It took more time than necessary because I upgraded Eclipse
>and did a reinstall of ptII and kepler sources so I could
>be sure.  It also took more time because the error message
>was a NullPointerException and I had not seen this sort
>of error before.
>Now, I'm facing problems with Eclipse again?
>I'm seeing errors about cipres PAUPInfer class?
>It does not build in Eclipse, so I excluded it, and
>then I had to remove some files from actors
>and then trash ~/.kepler and run ant buildkarlib
>I eventually did all that stuff and now I was able to work.
>A couple of comments:
>1) We all, (me especially) need to be more careful about not breaking
>the build and Kepler in general
>2) Kepler needs to be restructured so that it does not require the
>entire library to be present and working at startup.  Ptolemy II does
>this so as to avoid problems like PAUPInfer.  I don't know what this
>class does, and since I'm not using it, I shouldn't care.  This would
>help start up time.  I think that this might possibly be worth
>considering implementing before 1.0.
>3) The Eclipse instructions are very complex.  We were never able to
>help Sivagowri Swaminathan <sivagowri at hotmail.com> to his or my
>satisfaction.  BTW - Under Eclipse 3.2.0 (rc1), with java 1.5.0_06,
>the svg icons are not visible for me?  Not sure why.
>4) The limitation about being able to run only one Kepler because
>of the database is troubling.  I'm running on a shared Windows
>server.  If I wanted to use Kepler in a class and have students
>run on this server, would I be able to?
>Anyway, those are some random thoughts.  As I said, I'm not
>at all upset about these issues, and I really enjoy contributing
>and collaborating with you all.  I think Kepler is pretty slick,
>I like what you've done with Ptolemy and appreciate you putting
>up with Ptolemy's (and my) ideosyncracies.
>Kepler-dev mailing list
>Kepler-dev at ecoinformatics.org

More information about the Kepler-dev mailing list