[kepler-dev] Building kepler & ptII in Eclipse

Paul Allen pea1 at cornell.edu
Wed Feb 27 06:58:17 PST 2008

Thanks. This had made things much better and I can run the Kepler UI 
from Eclipse.

I do get one complaint from the system on stdout, even though I did 
rereun the buildkarlib ant task.

Unable to process kar file: C:\workspace\rad-1\kepler\kar\actors\ImageJ.kar


ben leinfelder wrote:
> I've changed and committed the classpath.default file to use the new 
> opendap jars that Daniel Crawl committed.
> With that change in my workspace I'm not having any trouble running 
> under Eclipse when using the HEAD of both kepler and ptII
> -ben
> On Feb 26, 2008, at 9:34 AM, Matthew Jones wrote:
>> Yes, you should be able to build from the HEAD.  Check your .classpath
>> file against the .classpath.default and be sure they match. If not, then
>>  copy .classpath.default onto your .classpath file and refresh, being
>> careful of course to not overwrite your local changes if any.  If you
>> still get compile errors, then we probably need to update
>> .classpath.default -- sometimes changes sneak in that we don't catch in
>> the Eclipse files.  One recent change has been in the IOPort* classes,
>> which were recently moved from Kepler's exp directory back into the
>> Ptolemy tree -- this means that the previous exclusions for these files
>> need to be removed from .classpath.  The updated .classpath.default
>> should reflect this. If you are getting class not found errors for
>> IOPort and related classes, this is probably the problem.
>> Matt
>> Paul Allen wrote:
>>> Quick question: Should I be able to build kepler and ptII from the HEAD
>>> of those CVS repositories at this point in time?
>>> I had been using Eclipse for development using a mid-Nov. version of
>>> those sources. Following the instructions in
>>> http://www.kepler-project.org/Wiki.jsp?page=UsingEclipseForKeplerDevelopment 
>>> worked like a charm to get things running in Eclipse.
>>> Just yesterday I updated both kepler and ptII from the HEAD of both CVS
>>> repositories. The only change I made to what I got from CVS was to 
>>> replace
>>>    <classpathentry kind="lib"
>>> path="lib/jar/opendap/opendap-Not.A.Release.jar"/>
>>>    with
>>>    <classpathentry kind="lib" 
>>> path="lib/jar/opendap/opendap-0.0.8.jar"/>
>>>    in kepler/.classpath.default
>>> Most of the problems seem to be classes that are missing from the ptII
>>> HEAD. Anybody else experiencing this?
>>> Thanks,
>>> -Paul
>>> _______________________________________________
>>> Kepler-dev mailing list
>>> Kepler-dev at ecoinformatics.org
>>> http://mercury.nceas.ucsb.edu/ecoinformatics/mailman/listinfo/kepler-dev 
>> -- 
>> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>> Matthew B. Jones
>> Director of Informatics Research and Development
>> National Center for Ecological Analysis and Synthesis (NCEAS)
>> UC Santa Barbara
>> jones at nceas.ucsb.edu                       Ph: 1-907-523-1960
>> http://www.nceas.ucsb.edu/ecoinfo
>> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>> _______________________________________________
>> Kepler-dev mailing list
>> Kepler-dev at ecoinformatics.org
>> http://mercury.nceas.ucsb.edu/ecoinformatics/mailman/listinfo/kepler-dev

More information about the Kepler-dev mailing list