[kepler-dev] [Bug 3097] - incorrect classpath in generated ptexecute.sh and momlexecute.sh

bugzilla-daemon@ecoinformatics.org bugzilla-daemon at ecoinformatics.org
Tue Apr 15 20:01:20 PDT 2008


------- Comment #6 from cxh at eecs.berkeley.edu  2008-04-15 20:01 -------
I tried wfexecute, it looks pretty slick, below are some comments.
- The name is a little funny.  wtf comes to mind, which is vulgar.
Maybe call it wfexec?  I dunno.
- Only wfexecute.bat is created?  What about Unix?
- Perhaps the Usage message should indicate which of -nogui/gui
and -nocache/cache are the defaults.
- A comment at the top about what the script does might help.
- When I run:
.\wfexecute -gui demos/getting-started/03-ImageDisplay.xml
The image displays and then exits.  Perhaps there should be
a way to have the output stay visible?
- Perhaps the rule that builds wfexecute.bat should also build
the kepler.jar file as the script will not work unless kepler.jar
is present.  Maybe the build directory should also be in the
path of this script?  I'm not sure about that though.

Also, about ClassPathHacker, I think the name should be changed.
I'm quite sad that the term "Hack" has been maligned by non-hackers
to mean something evil, but it is a reality.  ClassPathMunger
might be an alternative name.  

Just my $0.02

More information about the Kepler-dev mailing list