[kepler-dev] [kepler-users] GDAL format Translator Crashes my workflow

Chad Berkley berkley at nceas.ucsb.edu
Tue Apr 1 11:37:46 PDT 2008

Hi Niels,

I've been looking into this and I think you're sending the GDAL Format 
Translator the wrong file type.  It's expecting a GTIFF and you're 
giving it an xml file.  Take a look at 
kepler/workflows/test/gdal-test.xml for an example.  Let me know if it 
still won't work for you.

The error handling on the JNI connection between the GDAL C code and the 
java interface is not very good.  That's why it just crashes when 
something goes wrong.  Not optimal, I know but the interface is pretty 
lacking when it comes to error handling.


Niels Hoffmann wrote:
> Hi Chad,
> Here's the workflow as well as the wms specification file for gdal. The 
> WMS Service is behind our Firewall, so you won't be able to access it.
> As I explained in the original email, if I run the following on the 
> command prompt I get a valid Tif file.
> C:\FWTools2.1.0>gdal_translate -ot Byte -of GTiff gdal_wms.xml gdal_wms.tif
> I'm running Kepler 1.0.0rc1 on WinXp sp2.
> I basically copied part of the workflow from demos\ENM\GDAL_h1K_NS.xml.
> What I noted is that if I open the GDAL Format Translator actor in that 
> workflow it has dropdowns for 3 of the parameters:
> If I grab the actor in a new project from the GeometricOperation 
> components it does not have those dropdowns:
> Might it be that there are 2 different versions installed? I tried both 
> (dragging the one from the components and copying the one out of the 
> sample workflow) and both are crashing.
> I also have FWTools 2.1 installed (1.6.0dev) as well as the GDAL 
> Binaries in my Python installation (1.5). Is the actor grabbing GDAL 
> from the system path or is it locally to the Kepler install? (I noticed 
> the 1.2 dll sitting in the Kepler\lib folder)
> Cheers,
> =============================
> Hi Niels,
> I'm looking into this.  Could you email me the workflow you are using?
> thanks,
> chad
> niels hoffmann wrote:
>> Hi,
>> I am trying to use a GDAL Format Translator to convert a WMS service 
>> to a GeoTiff.
>> I created a xml file with my WMS connection settings as specified by 
>> the GDAL Documentation. If I run it from the GDAL Command prompt 
>> (FWTools) I get a proper result.
>> But if I use the same xml file as input for the GDAL Format Translator 
>> my workflow crashes.
>> Attached is the dump that gets created.
>> Anybody knows what my problem is?
>> Is there maybe another way to use a WMS service in Kepler?
>> Kind regards,
>> Niels Hoffmann
>> ------------------------------------------------------------------------
>> _______________________________________________
>> Kepler-users mailing list
>> Kepler-users at ecoinformatics.org
>> http://mercury.nceas.ucsb.edu/ecoinformatics/mailman/listinfo/kepler-users 
>> Niels Hoffmann
>> GIS Specialist
>> ph: +64 (0)7 859 3726
>> fax: +64 (0)7 859 3701
>> Email: hoffmannN at landcareresearch.co.nz
>> Landcare Research
>> Gate 10
>> Silverdale Road
>> Hamilton

More information about the Kepler-dev mailing list