[kepler-dev] [kepler-users] Actor packaging

Kenneth Evans evans at aps.anl.gov
Mon Oct 29 14:21:39 PDT 2007


I did a synchronize with the Ptolemy CVS and found no discrepancies.  I did
this on Saturday.  That site is changing, however, and would now show

The second problem (also mentioned in a previous post) is that MacAfee
immediately removes shutdown.bat (2) during CVS updates or checkouts.  This
seems to foul up CVS.  According to our IT department, shutdown.bat could be
changed as follows:

McAfee seems to only detect:
"C:\WINDOWS\system32\shutdown -r -t 0 -f"

and if you change the string slightly:
"C:\WINDOWS\system32\shutdown -r -t 1 -f"

"C:\WINDOWS\system32\shutdown -r -f -t 0"

I cannot prevent the deletion at work, so fixing it so there is no false
positive would be good.

I have already redone the checkouts twice, and it is pretty time consuming.
Perhaps I can do it again at home, where I don't get the MacAfee problem.

Later:  Following Chad's suggestion I did full-clean ptolemy run-dev and got
the same error.  (This is what I did before with the addition of



-----Original Message-----
From: Dan Higgins [mailto:higgins at nceas.ucsb.edu] 
Sent: Monday, October 29, 2007 4:03 PM
To: Kenneth Evans
Subject: Re: [kepler-users] Actor packaging

    I have seen the error you report a few times in the nightly build. 
It was caused by a corrupted checkout from the Ptolemy CVS archive (the 
checkout was incomplete but gave no error message). I 'fixed' it by 
checking out a fresh version of Ptolemy.  This only occurred once in a 
while and repeating the checkout fixed it, so I was  unable to repeat 
the problem and determine what was causing it.


Kenneth Evans wrote:
> Dan,
> I previously did a full ant build.  I put the results in a previous post,
> but I've probably put too much out there, and it is getting split between
> the two mailing lists.  Let me repeat it:
> Buildfile: C:\Documents and Settings\evans\My
> Documents\Eclipse\Work\kepler\build.xml
> ptolemy:
> config:
> init:
> prepare:
> C:\Documents and Settings\evans\My
> Documents\Eclipse\Work\kepler\build.xml:761: The following error occurred
> while executing this line:
> C:\Documents and Settings\evans\My
> Documents\Eclipse\Work\kepler\build-ptolemy.xml:106: C:\Documents and
> Settings\evans\My
> Documents\Eclipse\Work\kepler\${env.PTII}\ptolemy\distributed\config not
> found.
> Total time: 273 milliseconds
> The targets were full-clean ptolemy buildkarlib run-dev.  This was the
> second try.  I didn't get the output from the first.  After doing the ant
> build, I got different errors in Eclipse, so it did something.
>         -Ken

Dan Higgins                                  higgins at nceas.ucsb.edu
http://www.nceas.ucsb.edu/    Ph: 805-893-5127
National Center for Ecological Analysis and Synthesis (NCEAS) Marine Science
Building - Room 3405
Santa Barbara, CA 93195

More information about the Kepler-dev mailing list