[kepler-dev] FW: latest kepler and java 5.0? build problems

Dan Higgins higgins at nceas.ucsb.edu
Mon Mar 21 13:41:31 PST 2005

I think this is a problem with the code in the src/doc dir not being 
compatible with Java 1.5.  One 'solution' is simply to delete the code 
in that dir. [The other is to switch to java 1.4.2.


Robin Schroeder wrote:

>>I just updated my copy of kepler from the ecoinformatics.org repository and ran into a number of problems when I went to compile. 
>>I ran the 'clean' target in the build-ptolemy.xml ant file. Then I ran the 'clean' and 'ptolemy' targets in the build.xml file without issue. When I ran the run-dev target in the build.xml ant file, I got the following:
>>Compiling 415 source files to C:\cvsRep\kepler\build\classes
>>C:\cvsRep\kepler\build\src\doc\doclets\ActorClassWriter.java:31: cannot find symbol
>>symbol  : class ClassTree
>>location: package com.sun.tools.doclets
>>import com.sun.tools.doclets.ClassTree;
>>C:\cvsRep\kepler\build\src\doc\doclets\ActorClassWriter.java:32: cannot find symbol
>>symbol  : class DocletAbortException
>>location: package com.sun.tools.doclets
>>import com.sun.tools.doclets.DocletAbortException;
>>C:\cvsRep\kepler\build\src\doc\doclets\ActorClassWriter.java:33: cannot find symbol
>>symbol  : class VisibleMemberMap
>>location: package com.sun.tools.doclets
>>import com.sun.tools.doclets.VisibleMemberMap;
>>C:\cvsRep\kepler\build\src\doc\doclets\ActorClassWriter.java:34: cannot find symbol
>>symbol  : class ClassWriter
>>location: package com.sun.tools.doclets.standard
>>import com.sun.tools.doclets.standard.ClassWriter;
>>C:\cvsRep\kepler\build\src\doc\doclets\ActorClassWriter.java:35: cannot find symbol
>>symbol  : class ConfigurationStandard
>>location: package com.sun.tools.doclets.standard
>>import com.sun.tools.doclets.standard.ConfigurationStandard;
>>C:\cvsRep\kepler\build\src\doc\doclets\ActorClassWriter.java:36: cannot find symbol
>>symbol  : class HtmlStandardWriter
>>location: package com.sun.tools.doclets.standard
>>import com.sun.tools.doclets.standard.HtmlStandardWriter;
>>C:\cvsRep\kepler\build\src\doc\doclets\ActorClassWriter.java:67: cannot find symbol
>>symbol: class ClassWriter
>>public class ActorClassWriter extends ClassWriter {
>>C:\cvsRep\kepler\build\src\doc\doclets\ActorClassWriter.java:74: cannot find symbol
>>symbol  : class ConfigurationStandard
>>location: class doc.doclets.ActorClassWriter
>>    public ActorClassWriter(ConfigurationStandard configuration,
>>... it goes on and on...
>>100 errors
>>C:\cvsRep\kepler\build.xml:344: Compile failed; see the compiler error output for details.
>>BUILD FAILED (total time: 1 minute 5 seconds)
>>I am running kepler with Netbeans 4.0 and java sdk 1.5.0 I checked on a few of these missing classes and while they are included in the Java 1.4.x tools.jar, they are not included in java 1.5. tools.jar. However, the first few that I checked did not show up in the depricated page in the 1.5 api. Perhaps they have moved? I am not sure. Has anyone had problems similar to this?  Can anyone suggest a fix?
>>Robin Tori Schroeder
>>Senior Software Developer
>>International Institute for Sustainability
>>Arizona State University 
>>robin.schroeder at asu.edu
>kepler-dev mailing list
>kepler-dev at ecoinformatics.org

Dan Higgins                                  higgins at nceas.ucsb.edu
http://www.nceas.ucsb.edu/    Ph: 805-893-5127
National Center for Ecological Analysis and Synthesis (NCEAS) 
Marine Science Building - Room 3405
Santa Barbara, CA 93195

More information about the Kepler-dev mailing list