[kepler-dev] Kepler alpha7

Edward A. Lee eal at eecs.berkeley.edu
Mon Jul 11 12:30:02 PDT 2005

At 09:44 AM 7/11/2005 -0700, Dan Higgins wrote:
>Hi All,
>     There are preliminary versions of the Kepler alpha7 installers in
>the http://kepler-project.org/dist/ direcory. However, the web site has
>not been updated with links to these new versions. I propose not to
>create these new link for a few days to let you all check workflows of
>particular interest. (I know that some do not work. :-(  ) Let me know
>if you find problems or need the links added right away.

I just tried it out, and looks pretty good...
Here are some immediate reactions:

- This release appears to be based on version 3.0 of Ptolemy II.
   This is two major releases behind!
   5.0 has been released in beta, and will be finalized shortly...
   There are quite a few features of 4.0 and 5.0 that would be quite
   useful to this community, such as actor-oriented classes, the
   dynamic dataflow (DDF) director, much better 3-D rendering actors
   in the GR domain, lifecycle actors like ModelReference, etc.

- Using the Windows installer, with all the defaults chosen, kepler
   does not get put in the Start menu... Perhaps it should be by default?

- The first demo (EML 2) fails with:
   ptolemy.kernel.util.IllegalActionException: Error parsing the eml 
package: Exception in DataTypeResolver.

- The demos are not well sized and placed for a standard laptop screen.
   Displays pop up off screen, and the workflows spill over to the right.
   Also, some of them come up panned so that the whole demo is not visible.

- The third demo (GEON Map Workflow) gives: java.lang.NullPointerException
         at org.sdm.spa.WebService.fire(WebService.java:466)
         at ptolemy.actor.AtomicActor.iterate(AtomicActor.java:266)
   This is probably because I was not on the net when I ran it,
   but it seems there should be a friendlier error message...

- Many of the plots are unlabeled (no title, no legend).

- Some of the demos have no annotations.

- The backprop model gives:
java.lang.UnsatisfiedLinkError: no backprop in java.library.path
         at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1517)
         at java.lang.Runtime.loadLibrary0(Runtime.java:788)


Edward A. Lee
Professor, Chair of the EE Division, Associate Chair of EECS
231 Cory Hall, UC Berkeley, Berkeley, CA 94720
phone: 510-642-0253 or 510-642-0455, fax: 510-642-2845
eal at eecs.Berkeley.EDU, http://ptolemy.eecs.berkeley.edu/~eal  

More information about the Kepler-dev mailing list