[kepler-dev] [Bug 1836] - search performance problems/bugs

bugzilla-daemon@ecoinformatics.org bugzilla-daemon at ecoinformatics.org
Fri Dec 17 12:54:44 PST 2004


------- Additional Comments From ldowney at lternet.edu  2004-12-17 12:54 -------
Giving some further input on this to help the debug progess.  When some of the 
users couldn't get any search results returned on their machines, they moved 
to a neighbor's machine (that had previously been successful in getting some 
search results) and performed the search there and some users were able to get 

The same problems occured when the search term was "test" or "Datos 
Meteorologicos."  With the latter, people tried various pieces of the search 
term.  Some used the entire search term, others used just "datos" or "Datos" 
and still were unable to get any search results.

Still other users tried re-booting Kepler and at least one user was successful 
in getting search results after doing that.

A few users tried to limit the search to just metacat and were still 
unsuccessful in getting any search results returned.  

Regardless of whether users are searching across a large data set or several 
large data sets, their expectation was some type of results, not a time out 
(or the progress indicator just stopping with no results returned).  Obviously 
the moving progress indicator is what lets users know that things are still 
working, and it is a nice feature.  However, if we anticipate even more 
slowness in the future, we will need to design some additional feedback, such 
as letting the user know the system is searching data set 1, then data set 2 

More information about the Kepler-dev mailing list